This wiki is intended for older versions of Motive. For the latest documentation, please refer to
docs.optitrack.com

Toolbar / Command Bar

Main pageMotive DocumentationToolbar / Command Bar

Page Scope

This page lists out the options that are available on the toolbar and the command bar of Motive.

Motive Command Bar
The Motive Toolbar

Toolbar


The Motive Toolbar
Icon Function Description
Toolbar Open 20.png
Open File Open Motive files: Project (TTP), Calibration (CAL), Takes (TAK), Rigid bodies (TRA), Skeletons (SKL).
Toolbar Save 20.png
Save Current Take Save currently opened Take.
Toolbar SaveAll 20.png
Save All Takes Save all of the Takes that are loaded in the Data pane.
Toolbar AppSettings 20.png
Application Settings Opens Application Setting pane for software preferences. Reconstruction settings will also be modified in this pane.
Tb8.png
Hide all panes Closes all the panes in the layout, leaving only the main viewport.
Toolbar Device Icon.png
Devices pane Opens the Devices (Cameras) Pane
Toolbar Calib 20.png
Calibration Opens Calibration Pane
Toolbar Data Icon.png
Data pane Opens the Data pane for managing takes.
Toolbar Assets Icon.png
Assets pane Opens the Assets pane for managing the list of tracked assets as well as integrated devices such as force plates and data acquisition devices.
Toolbar Properties Icon.png
Properties pane Opens the Properties pane for managing the properties of selected items in Motive.
Toolbar RigidBody .png
Builder pane Opens the Builder pane for defining or modifying rigid body or skeleton assets in Motive.
Toolbar Markerset Icon.png
Constraints pane Opens the Markersets pane for creating and configuring constraints for markers labels associated each assets.
Tb19.png
Edit Tools Pane Opens Edit Tools for post-processing pipelines.
Toolbar Labeling Icon.png
Labeling Pane Opens the Labeling pane for labeling the markers.
Toolbar GraphViews Icon.png
Graph View pane Opens Graph View pane for monitoring the channel data.
Toolbar Log 20.png
Log pane Opens the Status Log for monitoring the activity.
Toolbar Views 30.png
Viewport Adds extra Viewports.
Toolbar Probe 30.png
Probe pane Opens the Probe pane for collecting sample points using the Probe.
Toolbar Info 30.png
Info pane Opens the Info pane for monitoring real-time tracking data of a selected rigid body in Motive.

Command Bar


File

Options under the File tab.

Open File: Prompts user to select a file to open. Applicable files include Take files (.tak), Camera Calibration files (.cal), Motive user profile (.motive), Rigid Body definitions (.tra deprecated), Skeleton defintions (.skl deprecated).

Open Folder: Imports a session folder into Motive. All of the TAK files within the session folder will be loaded in the Data pane.

Import CSV: Import a list of Take names to record from a CSV file that contains Take names on each row. This allows users to plan which motions to capture ahead of the time (See: Data Recording page). Import CSV can also be used to load a Rigid Body that has been exported to CSV format from the Assets pane.


Open Recent: Shows a list of Motive compatible files that were recently loaded into Motive.


Save Take: Saves currently opened Take.

Save Take As... : Prompts the user to select a filename and a directory to save the current Take.

Save All Takes: Save all Takes from all of the sessions loaded in the Data pane.


Export Tracking Data... : Exports tracking data from a selected Take into the desired output format. See: Data Export.

Export Video... : Exports reference video to an AVI file. To play this file in Windows Media Player, a codec needs to be installed.

Export Audio... : Exports audio to into a WAV file. See: Audio Recording in Motive.


Export Calibration... : Exports the current system calibration file(.cal) to a desired location.

Export Profile As... : Exports the current software configurations into an application profile (MOTIVE).

Info2.png

Profile (MOTIVE) files: MOTIVE profile stores software configurations. Software setting such as applications settings, streaming setting, trackable assets, synchronization configurations, and/or device configurations can be saved into this file. This file can be exported and imported to configurations in Motive.

Export Assets... : Export just the assets (rigid bodies, skeletons, markersets) to a MOTIVE file.

Export Device Info... : Exports the devices currently connected to Motive into a CSV file (ie. Cameras and their serial numbers).


Update Default Profile: Manually update the current software configurations onto the default system profile. Which loads up at first when launching Motive and located under C:\ProgramData\OptiTrack\MotiveProfile.motive.


Exit: Closes the Motive application.

Edit

Options under the Edit tab.

Undo: Reverts data processing actions (i.e. deleting data, merging markers, filling gaps).

Redo: Reverts an Undo.


Trim Current Take: Archives the original take file and crops out the working range selected in the Graph View pane. For more information, read through the Trimming Captured Takes.


Settings: Opens the Application Settings pane.

Reset Settings: Sets all application settings to the default setting.

View

Options under the View tab.

Hide All: This closes all of Motive's panes except the main viewport.


Devices: Opens the Devices pane for controlling cameras and other devices in the system

Calibration: Opens the Calibration for calibrating the camera system.


Data: Opens the Data pane for managing the recorded captures.

Assets: Opens the Assets pane for managing the list of tracked assets as well as integrated devices such as force plates and data acquisition devices.

Properties: Opens the Properties pane for managing the properties of selected items in Motive.

Info: Opens the Info pane for monitoring real-time tracking data of a rigid body.

Builder: Opens the Builder pane for creating trackable models or assets. Specifically, this pane is used for creating rigid body models and skeleton models in Motive.

Constraints: Opens the Constraints pane for managing selected markerset assets.


Edit Tools: Opens the Edit Tools pane. For post-processing recorded marker data.

Labels: Opens the Labels pane. For monitoring, assigning, and/or modifying marker labels.


Graph 1 & Graph 2: Opens Graph View pane for monitoring the channel data.

Viewer: Opens an additional Viewport for additional viewports for monitoring 3D tracking and camera views.


Data Streaming pane: Opens the Data Streaming pane. See: Data Streaming

Log: Opens the Log pane for status messages.

Probe: Opens the Probe pane for using the Measurement Probe.

Toolbar: Toggles display of the Toolbar on/off.

Layout

Options under the Layout tab.

Warning2.png

Note: Layouts created versions prior to 2.0 are not compatible. Please re-create and update the layouts for use.

Calibrate: Displays panes applicable to system calibration. (Cameras, Perspective View, Camera Preview, Camera Calibration, Reconstruction)

Create: Displays panes applicable to asset creation and modification. (Project, Perspective View, Timeline, Skeleton, Rigid Bodies)

Capture: Displays panes applicable to capturing a take. (Project, Perspective View, Timeline)

Edit: Displays panes applicable to editing a take. (Project, Perspective View, Timeline, Edit Tools).


Create Layout: Saves the current layout. Saved custom layouts can be accessed from the drop-down menu located at the top-right corner of Motive.

Delete Layout: Deletes the saved custom layout.

Update Current: Updates the selected custom layout from the drop-down menu located at the top-right corner of Motive.

Set as Default: Sets the current layout as a default layout setup for starting Motive.


Custom Layouts: List of custom layouts that are created by the user. In the screenshot, Label Fix and Skeleton Label layouts are added as an example

Help

Options under the Help tab.

Contact Support...: Opens the OptiTrack support site.

OptiTrack Forums...: Opens the OptiTrack community forum


Quick Start: Links you to our Quick Start Guide.

Wiki...: Links you to the online documentation.

Product...: Links you to our Quick Start Guide.

News...: Opens NaturalPoint's news feed.

Startup News Check: This is a toggle for receiving notifications for Motive updates.


Licence Folder: Opens the folder location of your license files.

About Motive: Displays information about the version of Motive currently running.