Builder pane

Main PageBuilder pane

Page Scope

This page provides he Builder pane can be accessed under the View tab or by clicking the Toolbar RigidBody .png icon on the main toolbar.

Overview


Marker labels shown on some of the markers on the Actor skeleton

The Builder pane is used for creating and editing trackable models, also called trackable assets, in Motive. In general, rigid body assets are created for tracking rigid objects, and skeleton assets are created for tracking human motions.

When created, trackable models store the positions of markers on the target object and use the information to auto-label the markers in 3D space. During the auto-label process, a set of predefined labels gets assigned to 3D points using the solver pipeline, and the labeled dataset is then used for calculating the position and orientation of the corresponding rigid bodies or skeleton segments.

The trackable models can be used to auto-label the 3D capture both in Live mode (real-time) and in the Edit mode (post-processing). Each created trackable models will have its own properties which can be viewed and changed under the Properties pane. If new skeletons or rigid bodies are created during post-processing, the Take will need to be auto-labeled again in order to apply the changes to the 3D data.


Interface Overview

On the Builder pane, you can either create a new trackable asset or modify an existing one. Select the Type of asset you wish to work on, and then select whether you wish to create or make modifications to existing assets. Create and modify tools for different types asset will be explained in the sections below.
BuilderPane Overview 30.png

Rigid Body: Create


For creating rigid bodies, select the rigid body from the Type option and access the Create tab at the top. Here, you can create rigid body assets and track any markered-objects in the volume. In addition to standard rigid body assets, you can also create rigid body models for head-mounted displays (HMDs) and measurement probes as well.

Creating Rigid Body

Step 1.

Select all associated rigid body markers in the 3D viewport.

Step 2.

On the Builder pane, confirm that the selected markers match the markers that you wish to define the rigid body from.

Step 3.

Click Create to define a rigid body asset from the selected markers.

You can also create a rigid body by doing the following actions while the markers are selected:

  • Prespective View (3D viewport): While the markers are selected, right-click on the perspective view to access the context menu. Under the Rigid Body section, click Create From Selected Markers.
  • Assets pane: While the markers are selected in Motive, click on the add IconAdd.png button in the Assets pane.
  • Hotkey: While the markers are selected, use the create rigid body hotkey (Default: Ctrl +T).
  • Creating a rigid body from selected markers (4) using the right-click context menu.
  • Rigid body defined from the selected markers.

Step 4.

Once the rigid body asset is created, the markers will be colored (labeled) and interconnected to each other. The newly created rigid body will be listed under the Assets pane.

Info2.png

Defining Assets in Edit mode:

If the rigid bodies, or skeletons, are created in the Edit mode, the corresponding Take needs to be auto-labeled. Only then, the rigid body markers will be labeled using the rigid body asset and positions and orientations will be computed for each frame. If the 3D data have not been labeled after edits on the recorded data, the asset may not be tracked.
Creating a rigid body

Creating HMD Rigid Body

Creating an HMD rigid body in the Builder pane.

This feature can be used only with HMDs that have the OptiTrack Active HMD clips mounted.

For using OptiTrack system for VR applications, it is important that the pivot point of HMD rigid body gets placed at the appropriate location, which is at the root of the nose in between the eyes. When using the HMD clips, you can utilize the HMD creation tools in the Builder pane to have Motive estimate this spot and place the pivot point accordingly. It utilizes known marker configurations on the clip to precisely positions the pivot point and sets the desired orientation.

Info2.png

HMDs with passive markers can utilize the External Pivot Alignment tool to calibrate the pivot point.

Steps

  1. First of all, make sure Motive is configured for tracking active markers.
  2. Open the Builder pane under View tab and click Rigid Bodies.
  3. Under the Type drop-down menu, select HMD. This will bring up the options for defining an HMD rigid body.
  4. If the selected marker matches one of the Active clips, it will indicate which type of Active Clip is being used.
  5. Under the Orientation drop-down menu, select the desired orientation of the HMD. The orientation used for streaming to Unity is +Z forward and Unreal Engine is +X forward, or you can also specify the expected orientation axis on the client plugin side.
  6. Hold the HMD at the center of the tracking volume where all of the active markers are tracked well.
  7. Select the 8 active markers in the 3D viewport.
  8. Click Create. An HMD rigid body will be created from the selected markers and it will initiate the calibration process.
  9. During calibration, slowly rotate the HMD to collect data samples in different orientations.
  10. Once all necessary samples are collected, the calibrated HMD rigid body will be created.

Creating Measurement Probe Rigid Body

Calibrated probe in Motive

You can also define a measurement probe using the Builder pane. The measurement probe tool utilizes the precise tracking of OptiTrack mocap systems and allows you to measure 3D locations within a capture volume. For more information, please read through the Measurement Probe Kit Guide

Creating a probe using the Builder pane

  1. Open the Builder pane under View tab and click Rigid Bodies.
  2. Bring the probe out into the tracking volume and create a rigid body from the markers.
  3. Under the Type drop-down menu, select Probe. This will bring up the options for defining a rigid body for the measurement probe.
  4. Select the rigid body created in step 2.
  5. Place and fit the tip of the probe in one of the slots on the provided calibration block.
  6. Note that there will be two steps in the calibration process: refining rigid body definition and calibration of the pivot point. Click Create button to initiate the probe refinement process.
  7. Slowly move the probe in a circular pattern while keeping the tip fitted in the slot; making a cone shape overall. Gently rotate the probe to collect additional samples.
  8. After the refinement, it will automatically proceed to the next step; the pivot point calibration.
  9. Repeat the same movement to collect additional sample data for precisely calculating the location of the pivot or the probe tip.
  10. When sufficient samples are collected, the pivot point will be positioned at the tip of the probe and the Mean Tip Error will be displayed. If the probe calibration was unsuccessful, just repeat the calibration again from step 4.
  11. Once the probe is calibrated successfully, a probe asset will be displayed over the rigid body in Motive, and live x/y/z position data will be displayed under the Probe pane.

Warning2.png

Caution

  • The probe tip MUST remain fitted securely in the slot on the calibration block during the calibration process.
  • Also, do not press in with the probe since the deformation from compressing could affect the result.

Info2.png

Note: Custom Probes

It's highly recommended to use the Probe kit when using this feature. With that being said, you can also use any markered object with a pivot arm to define a custom probe in Motive, but when a custom probe is used, it may have less accurate measurements; especially if the pivot arm and the object are not rigid and/or if any slight translation occurs during the probe calibration steps.

Rigid Body: Modify


The Builder pane has tools that can be used to modify the tracking of a rigid body that's selected in Motive. To modify rigid bodies, select a single rigid body and access the Modify tab at the top. This will bring up the options for editing a rigid body.

Refine

Click an asset in the Assets pane to highlight the Refine button in the Builder pane
Refinement progress bar

This feature is supported in Live Mode only.

The rigid body refinement tool improves the accuracy of rigid body calculation in Motive. When a rigid body asset is initially created, Motive references only a single frame for defining the rigid body definition. The rigid body refinement tool allows Motive to collect additional samples in the live mode for achieving more accurate tracking results. More specifically, this feature improves the calculation of expected marker locations of the rigid body as well as the position and orientation of the rigid body itself.

Steps

  1. Select View from the toolbar at the top, open the Builder pane.
  2. Select the Rigid Bodies from the Type dropdown menu.
  3. In Live mode, select an existing rigid body asset that you wish to refine from the Assets pane.
  4. Hold the physical selected rigid body at the center of the capture volume so that as many cameras as possible can clearly capture the markers on the rigid body.
  5. Click Refine in the Builder pane.
  6. Slowly rotate the rigid body to collect samples at different orientations until the progress bar is full.
  7. Once all necessary samples are collected, the Refine and Create + Refine buttons will appear again in the Builder pane and the refinements will have been applied.

Probe Calibration

The Probe Calibration feature under the rigid body edit options can be used to re-calibrate a pivot point of a measurement probe or a custom rigid body. This step is also completed as one of the calibration steps when first creating a measurement probe, but you can re-calibrate it under the Modify tab.

Steps

  1. In Motive, select the rigid body or a measurement probe.
  2. Bring out the probe into the tracking volume where all of its markers are well-tracked.
  3. Place and fit the tip of the probe in one of the slots on the provided calibration block.
  4. Click Start
  5. Once it starts collecting the samples, slowly move the probe in a circular pattern while keeping the tip fitted in the slot; making a cone shape overall. Gently rotate the probe to collect additional samples.
  6. When sufficient samples are collected, the mean error of the calibrated pivot point will be displayed.
  7. Click Apply to use the calibrated definition or click Cancel to calibrate again.

Location/Orientation

Options for translating and rotating the rigid body pivot point.

The Modify tab is used to apply translation or rotation to the pivot point of a selected rigid body. A pivot point of a rigid body represents both position (x,y,z) and orientation (pitch, roll, yaw) of the corresponding asset.

Info2.png

You can also use the Gizmo tools to quickly make modify the pivot point of a rigid body

Location

Use this tool to translate a pivot point in x/y/z axis (in mm). You can also reset the translation to set the pivot point back at the geometrical center of the rigid body.

Orientation

Use this tool to apply rotation to the local coordinate system of a selected rigid body. You can also reset the orientation to align the rigid body coordinate axis and the global axis.
When resetting the orientation, the rigid body must be tracked in the scene.

OptiTrack Clip Tool

The OptiTrack Clip Tool basically recalibrates HMDs with OptiTrack HMD Clips to position its pivot point at an appropriate location. The steps are basically the same as when first creating the HMD rigid body.

Spherical Pivot Placement

This feature is useful when tracking a spherical object (e.g. ball). It will assume that all of the markers on the selected rigid body are placed on a surface of a spherical object, and the pivot point will be calculated and re-positioned accordingly. Simply select a rigid body in Motive, open the Builder pane to edit rigid body definitions, and then click Apply to place the pivot point at the center of the spherical object.

Skeleton: Create

To create skeletons in Motive, you need to select the skeleton option from the type dropdown menu and access the Create tab at the top. Here, you select which skeleton markerset to use, choose the calibration post, and create the skeleton model.

Creating Skeleton

Defining skeleton from a skeleton markerset.

Step 1.

From the skeleton creation options on the Builder pane, select a skeleton markerset template from the Template drop-down menu. This will bring up a skeleton avatar displaying where the markers need to be placed on the subject.

Step 2.

Refer to the avatar and place the markers on the subject accordingly. For accurate placements, ask the subject to stand in the calibration pose while placing the markers. It is important that these markers get placed at the right spots on the subject's body for the best skeleton tracking. Thus, extra attention is needed when placing the skeleton markers.

Info2.png

The magenta markers indicate the segment markers that can be placed at a slightly different position within the same segment.

Step 3.

Double-check the marker counts and their placements. It may be easier to use the 3D viewport in Motive to do this. The system should be tracking the attached markers at this point.

Step 4.

In the Builder pane, make sure the numbers under the Markers Needed and Markers Detected sections are matching. If the skeleton markers are not automatically detected, manually select the skeleton markers from the 3D perspective view.

Step 5.

Select a desired set of marker labels under the Labels section. Here, you can just use the Default labels to assign labels that are defined by the markerset template. Or, you can also assign custom labels by loading previously prepared marker-name XML files in the label section.

Step 6.

Next step is to select the skeleton creation pose settings. Under the Pose section drop-down menu, select the desired calibration post you want to use for defining the skeleton. This is set to the T-pose by default.

Step 7.

Ask the subject to stand in the selected calibration pose. Here, standing in a proper calibration posture is important because the pose of the created skeleton will be calibrated from it. For more details, read the calibration poses section.

Step 8.

Click Create to create the skeleton. Once the skeleton model has been defined, confirm all skeleton segments and assigned markers are located at expected locations. If any of the skeleton segment seems to be misaligned, delete and create the skeleton again after adjusting the marker placements and the calibration pose.

Info2.png

In Edit Mode

If you are creating a skeleton in the post-processing of captured data, you will have to auto-label the Take to see the skeleton modeled and tracked in Motive.

Skeleton: Modify


Recalibrate From Selection

You can also select a skeleton and use CTRL + R hotkey to refresh the tracking of skeleton if needed.

Existing skeleton assets can be recalibrated using the existing skeleton information. Basically, the recalibration recreates the selected skeleton using the same skeleton markerset. This feature recalibrates the skeleton asset and refreshes expected marker locations on the assets.

To recalibrate skeletons, select all of the associated skeleton markers from the perspective view along with the corresponding skeleton model. Make sure the selected skeleton is in a calibration pose, and click Recalibrate. You can also recalibrate from the context menu in the Assets pane or in the 3D Viewport.

Warning2.png

Skeleton recalibration do not work with skeleton templates with added markers.

  • Recalibrate from selected marker in the Assets pane.
  • Recalibrate from selected marker in the Assets pane.
  • Recalibrate from selected marker in the Perspective View pane.

Asset Model Markers

You can add or remove asset model markers from a rigid body or a skeleton using the Builder pane. This is basically adding or removing markers to the existing rigid body and/or skeleton definition. To do this, you will need to make sure the selection of Asset Model Markers is enabled in the Perspective viewport. Then, follow the below steps to add or remove markers:

Steps

  1. Enable selection of Asset Model Markers.
  2. Access the Modify tab on the Builder pane.
  3. Select a skeleton or a rigid body that you wish to modify the asset markers for.
  4. CTRL + left-click on an asset model(s) marker that's associated with the selected asset.
  5. On the Asset Model Markers in the Builder pane, click + for adding the marker to the definition or - for removing the asset model marker.
  6. Use the Constraints pane to modify marker label and/or colors.

Marker Sticks

This feature works for skeleton assets only

For skeleton marker sticks, you can use the Builder pane to add/remove markers sticks and also modify the color of the sticks as needed.